Personal blog of Alex Muratov

X11 strikes back – MIT-MAGIC-COOKIE-1 data did not match

Posted on April 9, 2012 | in Linux, X-Windows, X11 | by

Oh no!

Today I again experienced this weird X11 error: when I try to launch a GUI from a Linux CLI, instead of a beautiful (actually not) window I saw this error message:

Xlib: connection to "localhost:10.0" refused by server Xlib: PuTTY X11 proxy: MIT-MAGIC-COOKIE-1 data did not match Error: Can't open display: localhost:10

Well, I was pretty sure that I already fixed it, but it appears that I have to fix it again.

After some search in Google I finally figured out how to do it. I knew but I forgot 😉
Important: I have to login using my personal account and the “su” to another account. Let’s say my account is “user#1” and the management account is “user#2”.

That’s all!
But why it happens?!

TAGS: , ,

5 Responses to “X11 strikes back – MIT-MAGIC-COOKIE-1 data did not match”

  1. Mike says:

    Thanks this did the trick!

  2. flink says:

    Thanks for posting this little gem. I’ve been messing with my systems all morning and it wasn’t until I found your post that I was able to solve my issue.

    I had two different cookies. I deleted them both (using xauth remove) and logged in and my windows would forward again.

  3. Nazeer Ahmed says:

    Even after adding

    xauth add

    It still giving me below issue.

    Xlib: connection to “localhost:10.0” refused by server

    Xlib: PuTTY X11 proxy: MIT-MAGIC-COOKIE-1 data did not match

     

     

     

     

  4. Ali says:

    Thanks Alex !!! it worked for me 🙂

Leave a Reply

BOINC

BOINC

Ads

Subscribe to Blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Calendar

April 2012
M T W T F S S
« Mar   Aug »
 1
2345678
9101112131415
16171819202122
23242526272829
30  
%d bloggers like this: